Portal » Forum   FAQ   Search  
Register  Login
Portal » Forum 206CC Forums 206CC General

Engine help :(

Anything related to the 206CC

Engine help :(

Postby Emzy90 » Sat May 30, 2020 6:55 pm

Good evening,

2 years ago I brought my Peugeot 206cc 1.6 57 plate. Last year on a hot sunny day the I was driving home from work and all of a sudden the engine decided to cut out on me came up with battery and handbrake on the dash but I was able to start the engine back up straight away this happened 3 or 4 times but I decided to not drive the car for a while as I mainly use it in the summer. I did drive it plenty in winter but when I checked the coolant this year I noticed it was a weird colour so I took it to a garage and they drained all the coolant and replaced it. Also had a battery issue as I tried to turn the engine over and the battery was flat so the bf jump started the car which got it working again so I asked the garage to check the battery which they said was fine. Obviously during lockdown the car has not been used much just to go on small trips to the shops to get food. Anyways, so I decided to take it to work with me today and as I drove back home the car decided to die on me several times on my way home but again starting straight up all times. I was wondering if anyone could give me any advice on what the issue could be?

Thanks

Emma :)
Emzy90
 
Posts: 3
Joined: Sat May 30, 2020 6:30 pm

Re: Engine help :(

Postby IanL » Sat May 30, 2020 7:50 pm

I've heard of this before, and it turned out to be a small piece of leaf in the fuel tank blocking the pump intake. Once the engine stops, the leaf falls away, so it will start again, but with the pump running, eventually the cycle repeats.

If that is your problem, you need to remove the pump and look for the offending item.
IanL
 
Posts: 1315
Joined: Wed May 13, 2015 10:34 pm
Location: Jersey, Channel Islands

Re: Engine help :(

Postby Greenjim » Mon Jun 01, 2020 8:42 pm

I had the same problem at the start of the year. The code reader just came up with an ignition system fault. So I first cleaned the MAP sensor then cleaned the throttle body nothing. Then believing it to be the power I put a new battery in and new terminals still nothing. But as I knew I was getting fuel it meant a bad coil or the crankshaft position sensor. I changed the sensor as this is only a cheap part and that was the problem. The car instantly ran better then ever so I would recommend to start with the crankshaft position sensor
Greenjim
 
Posts: 1
Joined: Mon Jun 01, 2020 8:27 pm

Re: Engine help :(

Postby Emzy90 » Wed Jun 03, 2020 7:23 am

Thank you so much for your help I hope it is a cheap fix I think I'll cry if it's not lol. It's booked in the garage today as I have no idea about cars (like most women - not being sexist lol). I will keep you updated on what the fault is.
Emzy90
 
Posts: 3
Joined: Sat May 30, 2020 6:30 pm

Re: Engine help :(

Postby Spitfire6 » Wed Jun 03, 2020 2:35 pm

Good luck!
Peugeot 206 CC 2L 16V 4cyl 2002. Mobil 1 FS 0W40 Oil. Lamps 80% LED.
Triumph GT6 CC 2L5 12V 6Cyl 1972. Mobil 1 FS 0W40 Oil. Lamps 96% LED.
G6SBH.
S7 Engineer.
User avatar
Spitfire6
 
Posts: 241
Joined: Sat Nov 22, 2014 4:47 pm
Location: Great Britain


Return to 206CC General

Who is online

Users browsing this forum: Majestic-12 [Bot] and 2 guests