No Power from the BSI to Ignition?

Do you have a suggestion for the site, wish to leave feedback - do it here.
Post Reply
Tominator
Posts: 5
Joined: Mon Jun 10, 2013 7:40 pm

No Power from the BSI to Ignition?

Post by Tominator »

Can anyone assist with ID an electrical issue with my Sons 206. On returning home he found the electric window switch was not working so decided to rectify the problem himself. Unfortunatley, he messed this up and now the Car wont start. I have looked at the wiring and discovered it was an after fix - in order to fix the car, I removed the wiring for the windows to mitigate this as a problem but still no luck. I subsequently disconnected the battery to ensure it was fully charged after replacing - still no luck.
Problem: Power to the BSI but not to the ignition, No lights on dash board, center console reads 'Mode Eco'?
Solutions tried: All fuses Ok, All earth cables ok, Battery charged, Hazards work as does the central locking, Rebooted the BSI no success?
Does any one have any other ideas - it would be very much appreciated!!

Regards

Tom

User avatar
Capncol
Posts: 3751
Joined: Fri Nov 11, 2011 12:40 pm
Location: Reading & Southampton

Re: No Power from the BSI to Ignition?

Post by Capncol »

Do you know exactly what he did?
Cheers Col.


206cc 1.6ltr (Wifes toy)
Mercedes ML (workhorse)
Corvette C3 (my toy)

When requesting help of a technical nature, please give as much detail of the fault as possible along with details of exact model, engine size & type, gearbox, year, mileage, and any relevant work carried out to try to solve the problem to help us help you.
Better still, put the details in your signature.

Tominator
Posts: 5
Joined: Mon Jun 10, 2013 7:40 pm

Re: No Power from the BSI to Ignition?

Post by Tominator »

This is from a 1.1L, Peugeot 206, 2001, 3 dr hatch with 85,000 miles. The wires were disconnected from the window switch and he failed to notice the order they went in, this is why I removed them from the source, hoping it would solve the problem. He later mentioned that prior to this happening the ignition was taking longer to start the engine - not sure if this is linked?

User avatar
Capncol
Posts: 3751
Joined: Fri Nov 11, 2011 12:40 pm
Location: Reading & Southampton

Re: No Power from the BSI to Ignition?

Post by Capncol »

A 2001 model shouldn't have BSI. Look at the fusebox under the dash- Has it got a *fuse* marked shunt?
Cheers Col.


206cc 1.6ltr (Wifes toy)
Mercedes ML (workhorse)
Corvette C3 (my toy)

When requesting help of a technical nature, please give as much detail of the fault as possible along with details of exact model, engine size & type, gearbox, year, mileage, and any relevant work carried out to try to solve the problem to help us help you.
Better still, put the details in your signature.

Tominator
Posts: 5
Joined: Mon Jun 10, 2013 7:40 pm

Re: No Power from the BSI to Ignition?

Post by Tominator »

Yes-there is a grey fuse marked 'SH'!

Tominator
Posts: 5
Joined: Mon Jun 10, 2013 7:40 pm

Re: No Power from the BSI to Ignition?

Post by Tominator »

Does an 'SH' fuse mean that this is not the BSI, just a regular fuse box? When I removed this and replaced it after waiting 10-15 mins, the dials on the drivers console (speedo, rev counter etc) flickered on. BUT STILL NO POWER TO THE IGNITION and NO WARNING LIGHTS ON THE DASH & NO MOVEMENT IN FUEL GUAGE- Still doesn't start - Does anyone have any idea what this could be, any suggestions are much appreciated as I have exhausted all options that I can think off?
Dan

Tim206
Posts: 3
Joined: Sun Sep 01, 2013 5:43 pm

Re: No Power from the BSI to Ignition?

Post by Tim206 »

Hi, im having the same problem with my 206 hdi. I wondered if you ever managed to get it sorted or find out what was causing it?

Tominator
Posts: 5
Joined: Mon Jun 10, 2013 7:40 pm

Re: No Power from the BSI to Ignition?

Post by Tominator »

Hi,
Embarrassingly enough - it was the master fuse. This is located under the fuse box in the engine. You must unscrew the bolts securing the fuse box and lift it up to check underneath where you will see additional fuses under the front of the box!!! Hope this helps

Tim206
Posts: 3
Joined: Sun Sep 01, 2013 5:43 pm

Re: No Power from the BSI to Ignition?

Post by Tim206 »

Thank you VERY much, has totally baffeled me, hopefully mine is the same.

Tim206
Posts: 3
Joined: Sun Sep 01, 2013 5:43 pm

Re: No Power from the BSI to Ignition?

Post by Tim206 »

Mate, your a legend! here i was thinking i had ruined my car like a right tool. and now im buzzing, what a silly place to hide a fuse.lol. Thanks again

Post Reply