Portal » Forum   FAQ   Search  
Register  Login
Portal » Forum 206CC Forums problems Other

Horrific clattering from Throttle Body

All your other probs if any.

Horrific clattering from Throttle Body

Postby artois7 » Sat Feb 23, 2019 10:51 pm

Hi all,

Have a weird issue - the throttle body is producing an absolutely awful clattering sound, akin to a bag of spanners.

I've pulled the TB off and nothing is loose or rattling inside. The noise entirely goes away as soon as the MAP sensor is unplugged, but again, pulling the MAP sensor out and nothing is broken or loose.

I don't really understand this one - probably just going to replace the whole TB assembly from a breaker but would love to hear thoughts. 1.6 HDI incase it matters.
artois7
 
Posts: 7
Joined: Sat Feb 09, 2019 11:29 pm

Re: Horrific clattering from Throttle Body

Postby Capncol » Sat Feb 23, 2019 11:03 pm

Map sensor may be erratic causing TB to cycle rapidly. Live data on a good code reader would confirm
Cheers Col.


206cc 1.6ltr (Wifes toy)
Mercedes ML (workhorse)
Corvette C3 (my toy)

When requesting help of a technical nature, please give as much detail of the fault as possible along with details of exact model, engine size & type, gearbox, year, mileage, and any relevant work carried out to try to solve the problem to help us help you.
Better still, put the details in your signature.
User avatar
Capncol
 
Posts: 3705
Joined: Fri Nov 11, 2011 12:40 pm
Location: Reading & Southampton


Return to Other

Who is online

Users browsing this forum: No registered users and 2 guests