Portal » Forum   FAQ   Search  
Register  Login
Portal » Forum 206CC Forums problems Electrical

206cc 2.0 SE 2002 model Speedo/airbag fault

Electrical 206CC problems

Postby adam.potter206cc » Thu Apr 08, 2010 6:31 pm

Hi People,

I am new to this forum, hopefully someone will be able to help me.

My speedo has an intermittent fault, it will sometimes just drop to zero, or it will go right round to max and then die. I have found that if I back off the throttle, and slow down a bit, then accelerate again the speedo comes back to life. Also when this fault occurs most of the time it is accompanied by the airbag warning light, although on occasion these two faults have occured independently of each other.

A good friend of mine who is a mechanic, ran diagnostic tests on my car with his snap on solus machine, and it pulled up a code relating to low input from the vehicle speed sensor. I have been advised to replace the vehicle speed sensor as apparently this could be causing both of the faults that I have, failing that I am told it could be a possible fault with the speedo binnacle or the associated wiring, I initially suspected the comm 2000 unit may be at fault but it presented no problems on the diagnostic test.

I just wanted to ask your advice before I start spending money trying to rectify these issues.

Many Thanks,
Adam.
adam.potter206cc
 
Posts: 1
Joined: Thu Apr 08, 2010 6:13 pm

Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron